Puzzle-Wiki Technikecke

  • Kurze Info:



    Die Fehlermeldungen betreffen 2 benutzte Erweiterungen wobei die eine (DPL) auf vielen Seiten benutzt wird, um Listen zu erzeugen oder Daten abzufragen.

    Die neueste Version dieser Erweiterung fordert aber eine MediaWiki-Version >=1.35.

    Das akt. MW ist aber noch 1.31.

    Ein Update auf diese neue Version macht also ein komplettes Update des Wiki nötig, was ohne eine vorherige Sicherungskopie riskant wäre.

    Mit inzwischen >25.000 Bilder ist das eine riesige Menge an Daten, was so ein Update nicht gerade einfach macht.


    Die andere Möglichkeit (und evtl. einfacher): ich muss sehen, ob ich den Fehler in der jetzt benutzen Version dieser Erweiterung beheben kann.


    Das sind eben Probleme, wenn man eine Domain nicht selber hosten kann (sprich 24/7 müsste ein privater Rechner am Netz sein -> Strom!) und der Anbieter zwingend eine neue PHP Version einspielt. Man kann nur für eine gewisse Zeit die alte Version weiter benutzen, aber das verschiebt nur das Problem auf später.


    Ich versuche die nächsten Tage, eine Lösung zu finden.

  • Ein paar Informationen zum Wiki:


    Ich habe in den letzen Wochen versucht, die jetzigen Fehler im Wiki selbst irgendwie zu beheben. Diese sind durch ein Update auf eine neue Version von PHP durch den Anbieter aufgetreten. Die Probleme im Wiki macht die Erweiterung DPL, die ja nun fast überall benutzt wird.

    Leider sind meine Skills in PHP sehr begrenzt, so dass ich auch sehr viel Detektivarbeit investiert habe, um zu sehen, ob andere auch diese Fehler haben und beheben konnten.

    Ein paar kleine Meldungen konnte ich bereinigen, aber der jetzige große Fehler tritt z.B. bei allen Puzzles auf, bei denen auch Bilder vorhanden sind. Puzzles ohne Bilder werden korrekt angezeigt. Ich habe auch versucht, DPL nicht zu benutzen, was aber kaum möglich ist.


    Ich sehe nun keine andere Möglichkeit, doch das Wiki selbst upzugraden auf eine Version 1.35 der MediaWiki Software.

    Hier gibt es einige Dinge zu beachten:

    - Da ich z.Z. die Version 1.31 benutze muss ich erst auf 1.35 updaten und danach evtl. kann ich erst auf eine noch höhere gehen, empfohlen wird 1.38.4 oder 1.39.

    - Bevor ein Update gemacht werden kann, sollte man die Datenbank sichern und ebenso alle Bilder (plus einige kleine Dateien mit Einstellungen).

    - Alle verwendeten Erweiterungen müssen geprüft werden, ob es dort ebenfalls neue Versionen gibt bzw. ob diese überhaupt noch funktionieren.


    Erst dann kann eine neue Version eingespielt werden, dann das Upgrade durchgeführt werden und zum Schluß evtl. neue Fehler bereinigt werden.

    All dies ist leider sehr zeitaufwendig, so dass ich wohl erst in meinem WeihUrlaub dazu komme, wenn ich denn überhaupt zeitlich schaffe.


    Bis dahin kann ich nur leider jeden vertrösten und Geduld zu haben, aber ich will dieses Projekt gerne weiterführen.

    Auch in Zukunft wird es leider immer wieder solche Probleme geben, da es hier an 3 Stellen (eigentlich 4) zu Änderungen kommen kann:

    PHP als Grundlage für die Wiki-Software, MediaWiki als Grundsoftware, die eingesetzten Erweiterungen und die Datenbank im Hintergrund.


    Ich kann hier noch keinen Zeitplan geben oder einen Fertig-Termin nennen. Was ich machen soll, wenn alles nicht klappt, weiß ich noch nicht.

  • kar_bon Danke für die Infos! Ist echt sch..., Das ein Update einem alles so zerhaut! Drücke Dir die Daumen, dass Du es mit nicht mehr zu viel Zeit hinbekommst, ich vermisse es echt als Nachschlagewerk und sammele fleissig meine Puzzle mit Daten zum Einstellen!

    Trotzdem eine schöne Adventszeit!!!

  • aber ich will dieses Projekt gerne weiterführen.

    das ist schon mal super !


    Diese blöden Updates :mecker: :mecker: ...

    Ich vermisse es auch - und es war für die Registereinträge eine große Hilfe !

    Schade, dass wir Dir im Moment da keine Hilfe sein können. Aber wenn Du irgendwann wieder Hilfe brauchst, sag Bescheid


    Und mach Dir keinen Stress - wir sind ja geduldig :)

  • Danke für die Rückmeldung kar_bon! Ich habe hier auch ein paar Puzzles liegen, die ich noch prüfen möchte, ob sie im Wiki schon vorhanden sind. Aber das hat ja Zeit, macht dir keinen Stress! :)

  • Leider habe ich keine Ahnung, wie wir Dich dabei aufmuntern können ? - Aber danke für die Info.
    Brauchst Du SCHOKOLADE ? Oder können wir sonst irgendwie helfen ?
    Benötigst Du vom CHRISTKIND einen Spenden- oder Schlafpolster ?

    Wenn du glaubst es geht nicht mehr, kommt von irgendwo ein Lichtlein her!

    • Official Post

    Hallo kar_bon an dieser Stelle noch alles Gute zum neuen Jahr.


    Ich hoffe, es geht dir gut und du konntest schon ein bisschen am wiki "herumschrauben"? Gibt es irgendetwas, das wir tun können? Allein die Vorstellung, dass so viele Jahre deiner intensiven Arbeit brach liegen könnten :huh: ;(